jboss-5.0.0.GA在myeclipse6.5中配置启动错误处理和对应web端口的修改

星期一, 2009-02-23 | Author: Lee | JAVA-and-J2EE | 5,891 views

今天下了jboss-5.0.0.GA的正式版,在myeclips6.5中配置启动,报出下列异常:

WARN  [ClassLoaderManager] Unexpected error during load of:org.jboss.resource.metadata.repository.DefaultJCAMetaDataRepository

java.lang.UnsupportedClassVersionError: Bad version number in .class file

 at java.lang.ClassLoader.defineClass1(Native Method)

再看控制台的java版本的输出:23:27:19,203 INFO  [ServerInfo] Java version: 1.5.0_14,Sun Microsystems Inc.

23:27:19,203 INFO  [ServerInfo] Java VM: Java HotSpot(TM) Client VM 1.5.0_14-b03,Sun Microsystems Inc.

原来是jdk的版本不对升级自己电脑上的jdk到6.0,在指定jboss的jdk路径就能正常启动了;

在eclipse中配置新的jre(实际上是jdk):

流程:Window—–>Preferences—–>Java—->Installed JRES 然后选择新增 只是JRE home directory 选择的是jdk6.0的路径,选择jre不对的;如图

图片看不清,可点击查看,支持滚轮缩放….

installjre6.0

2.在jboss的jdk选择下选你刚才建的如图:

图片看不清,可点击查看,支持滚轮缩放….


jboss5jdk

关于jboss-5.0.GA的web服务端口的更改是:我的路径是D:\Servers\jboss-5.0.0.GA\server\default\deploy\jbossweb.sar 下的server.xml 修改8080端口即可

Tags:

文章作者: Lee

本文地址: https://www.pomelolee.com/332.html

除非注明,Pomelo Lee文章均为原创,转载请以链接形式标明本文地址

No comments yet.

Leave a comment

Search

文章分类

Meta