SVN客户端subclipse的安装

星期二, 2009-02-03 | Author: Lee | JAVA-and-J2EE | 10,686 views

其他的就不说了,直接对应相应的版本
New Remote Site,自定义一个名字,url选择下面其中一个
Name: Subclipse 1.4.x (Eclipse 3.2+)
URL: http://subclipse.tigris.org/update_1.4.x

Name: Subclipse 1.2.x (Eclipse 3.2+)
URL: http://subclipse.tigris.org/update_1.2.x

Name: Subclipse 1.0.x (Eclipse 3.0/3.1)
URL: http://subclipse.tigris.org/update_1.0.x
本人才用的myeclipse6.5自然选用http://subclipse.tigris.org/update_1.4.x
安装的时候遇见异常信息如下:Subclipse Integration for Mylyn 3.x (Optional) (3.0.0) requires plug-in “org.eclipse.mylyn.tasks.core (3.0.0)”, or compatible.
解决方法:第一个框框Integrations的勾干掉即可

至于服务端的安装,很久以前安装过,以后有时间再玩下;因今天安装遇见错误就记录下了;

Tags:

文章作者: Lee

本文地址: https://www.pomelolee.com/274.html

除非注明,Pomelo Lee文章均为原创,转载请以链接形式标明本文地址

4 Comments to SVN客户端subclipse的安装

liyz
2009 年 11 月 30 日

配置svn时常见的错误

用来研究如何为svn配置用户访问权限,耗费最长时间的是,总是碰到提示“无权打开根进行编辑操作”问题,百思不得其解,

1 不能检出
在本人的实际配置中,发现可以读写,但是死活不能检出。老是提示:无权打开根进行编辑操作 Read access denied for root of edit
解决方法如下:

svnserve.conf中的anon-access = none必须加上。如果设置成anon-access = read则必须在在authz文件中加上:

[/]

* = r

2、读取配置文件出错
在检出和导入时出现的读取svnserver.conf出错

svn 出现 svnserve.conf:12: Option expected
是因为subversion读取配置文件svnserve.conf时,无法识别有前置空格的配置文件

anon-access = read —-正确
anon-access = read —-错误

修改改配置文件时去掉#时要删除该行的空格。

注意,在authz里,可以定义组,一般是通过组来管理权限的,记得组要用@和用户进行区分

另外,多个project可以共享同一个passwd和authz,即多个project指向同一个passwd、authz

Thomaslii
2010 年 07 月 15 日

不错,多谢,您辛苦了。

I5A6
2011 年 04 月 06 日

使eclipse中subclipse插件变成英文菜单的配置项
修改eclipse\configuration\config.ini文件,

添加:osgi.nl=en_US

[…] eclipse的svn客户端安装见:http://www.pomelolee.com/274.html […]

Leave a comment

Search

相关文章

文章分类

Meta