前端项目package.json中dependencies和devDependencies包版本的说明

星期二, 2022-05-24 | Author: Lee | ajax, pagemaker, 前端 | 362 views

1、dependencie 配置当前程序所依赖的其他包。

2、devDependencie 配置当前程序所依赖的其他包,比如一些工具之类的配置在这里

主要是^大版本不变,只更新后面的小版本,以防止不兼容的情况

"dependencies":{ 
	"ace-builds": "^1.4.9",
    "antd": "^3.26.15",
    "axios": "^0.19.0",
    "bootstrap-datepicker": "^1.8.0"
}
 
"devDependencies": {
    "@babel/cli": "7.4.3",
    "@babel/core": "7.4.3",
    "@babel/plugin-proposal-class-properties": "7.4.0",
    "@babel/plugin-proposal-optional-chaining": "^7.9.0",
    "@babel/plugin-syntax-dynamic-import": "7.2.0"
}

^表示第一位版本号不变,后面两位取最新的

~表示前两位不变,最后一个取最新

*表示全部取最新

Tags:

文章作者: Lee

本文地址: https://www.pomelolee.com/2308.html

除非注明,Pomelo Lee文章均为原创,转载请以链接形式标明本文地址

No comments yet.

Leave a comment

Search

文章分类

Meta